Searching...
Browse AD FREE for less than 84¢ a month with an SHDb membership.

Bug Report

Created by Galactus, 3 y 29 d ago.

Report any functionality bugs you find.
Current buglist: Bug List v4.x
Please check the list before reporting a bug.



Please report the page and actions to cause the bug/error.
When having layout issues, please provide the OS and browser you're using.
The more details I have, the better I can fix it.

Comments

Aleazlllll
Bug Report
9 months member
72.3K
I created a battle but 2 who aren't even online already voted it did anyone have the same issue ?
show 1 reply
Galactus
Galactus 12 d
Bug Report
8+ year member
1.2M
It's not a bug, it's a feature.
The battle was created by a user that wasn't logged in. The first logged in user that recreates that battle gets it assigned to their name.
yes
yes 13 d
Bug Report
3 months member
16.1K
So I was checking the comic Lucifer page and the ustats for him glitches out meaning some of the lines like speed durability and stuff like like were invisible then clicking on the Ustats same thing but a bunch of numbers
show 7 replies
Galactus
Galactus 13 d
Bug Report
8+ year member
1.2M
Do you have a link? There are 6 quadrillion Lucifer profiles 😅
yes
yes 13 d
Bug Report
3 months member
16.1K
@Galactus How do I get the link ? Sorry I don’t really know anything about this stuff
yes
yes 13 d
Bug Report
3 months member
16.1K
@Galactus it’s the one with Lucifer in his black suit with what I’m guessing are his wings out and there like orange or something and he’s got his arm up
yes
yes 13 d
Bug Report
3 months member
16.1K
@Ezio Thanks for sending the link 🙏
Galactus
Galactus 13 d
Bug Report
8+ year member
1.2M
Thanks for reporting. I figured out how he did it. I will add some extra limit checks tonight.
Galactus
Galactus 12 d
Bug Report
8+ year member
1.2M
@yes @Ezio Bug has been fixed and I've deleted the faulty uStats.
Manvirishab
Bug Report
1 months member
408
@Galactus
This website to muchh lag after 5 min i dont know why
First my website is good for 5 min but after 5 min it get freezes i cannot do anything and even my ipad also get freezes .

Ipad 9
Wifi speed - 100mbps
Last edited: 20 d ago.
show 5 replies
Galactus
Galactus 20 d
Bug Report
8+ year member
1.2M
Could you tell me what pages you visit mostly, or maybe pages that you know make this lag happen?
Manvirishab
Bug Report
1 months member
408
I visit most pages like
1.THOR(MCU) VS SUPERMAN(DCEU)
2.OLD KING THOR VS RUNE KING THOR
3.COSMIC ARMOUR SUPERMAN VS RUNE KING THOR
Galactus
Galactus 20 d
Bug Report
8+ year member
1.2M
Some Battle pages take a bit longer due to the amount of comments, but not minutes.
I've checked with some external speed test websites, but they are all fast enough (max 1.8 seconds for the heaviest battle page)

You can try to clear your iPad Safari cache: Settings>Safari>Clear Cookies and Data. Quit Safari and reboot the iPad.
A 9th gen iPad should not have those issues. If the whole iPad becomes slow, it's not just a website (Safari) issue. You can have it checked by the seller, or an Apple store.
Manvirishab
Bug Report
1 months member
408
Ok bro thanks
Manvirishab
Bug Report
1 months member
408
Did you like my profile photo i changed it into RKT
MY FAV SUPERHERO
xerodeep
xerodeep 25 d
Bug Report
40 months member
234K
@Galactus, I recently noticed that at least in newer characters, new battles are showing up in the Newest Battles column but not in the Top Battles column like they used to. So the character's About page sometimes shows no battles or fewer than three when battles that used to show up there are only found on the Battles tab under Newest Battles. Just though I would let you know.
show 2 replies
Galactus
Galactus 25 d
Bug Report
8+ year member
1.2M
I've changed how the top x battles of a character are created. Read more on the update here: https://www.superherodb.com/forum/shdb-updates/100-3790/#c479937

In short; only battles are counted where that character (or team that character is in) get a vote.
Last edited: 25 d ago.
xerodeep
xerodeep 25 d
Bug Report
40 months member
234K
Okay, good to know. Missed that update post. Thank you!
Shadow_Rider
Shadow_Rider 1 mo 5 d
Bug Report
17 months member
27.9K
@Galactus, I am unable to view battles created in any sort of order e.g. number of votes, after page 2.
show 2 replies
Galactus
Galactus 1 mo 5 d
Bug Report
8+ year member
1.2M
@Ezio mentioned it yesterday. I did have (sort of) a fix, but that wasn't playing well with other pages.
Will be fixed soon.
Shadow_Rider
Shadow_Rider 1 mo 5 d
Bug Report
17 months member
27.9K
Thanks mate, no worries.
Ezio
Ezio 1 mo 7 d
Bug Report
66 months member
3M
This is not too important but filter only works in the first page of "All characters without SHDb stats" or " Battles created by ...". When you go to second page filter reset to default.
show 2 replies
Galactus
Galactus 1 mo 6 d
Bug Report
8+ year member
1.2M
I changed the way page urls are created. This fixed the problem.
I have checked other pages with multiple 'pages', they seem to work as well. If you find any weird thing, let me know.
Galactus
Galactus 1 mo 5 d
Bug Report
8+ year member
1.2M
I've reverted back to the previous situation. I have to look for a better solution. Will be continued...
xerodeep
xerodeep 4 mo 2 d
Bug Report
40 months member
234K
@Galactus, this has happened before where I go to edit something and click Add To Edit and the page refreshes with an error telling me someone is already editing it but it shows up in my edits on my Admin page. Usually I have still been able to edit in those cases if I just go out and come back in but in this case, when I go back in and click the Edit button, this one just refreshes the page. I clicked the Edit button a few times before I realized it was adding edits on top of each other and now I have the same edit listed multiple time as if I am editing more than one of the same thing. I thought I should report it in this case.
Last edited: 4 mo 2 d ago.
show 2 replies
Galactus
Galactus 4 mo 2 d
Bug Report
8+ year member
1.2M
You had multiple entries on editing the same thing. I've removed the duplicates, so it should not be a problem anymore.
Last edited: 4 mo 2 d ago.
xerodeep
xerodeep 4 mo 2 d
Bug Report
40 months member
234K
Yes, it seems to work now but only like it did for the others that I ran into this same bug with. If I go to the Edit page of the profile itself it tells me, "Someone else is already editing this." In order to edit it, I have to click the link on my Admin page. Then it works. I've run into that one multiple times. This was the first time it opened multiple entries of the same edit but you fixed that part.
Last edited: 4 mo 2 d ago.
Ezio
Ezio 4 mo 11 d
Bug Report
66 months member
3M
@Galactus Could you optimize battle page? sometimes it takes a long time and lots of bandwidth to find characters and create battle.
show 2 replies
Ezio
Ezio 4 mo 11 d
Bug Report
66 months member
3M
Most of the time it happens when I type a character name, if I copy/past that name it does not happen.
Galactus
Galactus 4 mo 7 d
Bug Report
8+ year member
1.2M
Been trying different ways of how people could type in names. There seem to be some issues when typing very slow. Like 1 character per 2 seconds slow.
Last edited: 4 mo 7 d ago.
xerodeep
xerodeep 4 mo 11 d
Bug Report
40 months member
234K
@Galactus, for some reason, I can't seem to post a comment on this battle page. The error I get is, "Whoops, something went wrong. :( " I was able to post comments on other pages but not this one. Can you tell why? Thank you!
Last edited: 4 mo 11 d ago.
show 7 replies
Galactus
Galactus 4 mo 11 d
Bug Report
8+ year member
1.2M
Just posted a test comment, and it works just fine. Please try again. It might have been a temporary hiccup. 🤷🏼‍♂️
xerodeep
xerodeep 4 mo 11 d
Bug Report
40 months member
234K
Nope, I still get the same error. It's been a few days since I first tried it too and I even tried it on multiple devices as well (desktop PC, laptop, phone). Strange! Not sure why I can't post there. Especially if you can.
Galactus
Galactus 4 mo 11 d
Bug Report
8+ year member
1.2M
Any other battles you can't post?
Galactus
Galactus 4 mo 11 d
Bug Report
8+ year member
1.2M
Do you get that error after or before you post a comment?
xerodeep
xerodeep 4 mo 11 d
Bug Report
40 months member
234K
I haven't tried posting to another battle yet but have posted to an image and this forum (obviously). I get the error as soon as I click the "Post" button after typing in my comment.
xerodeep
xerodeep 4 mo 11 d
Bug Report
40 months member
234K
Just ran a "test" on another battle and was able to post a comment in that one just fine. No idea why I can't in the one I mentioned.
xerodeep
xerodeep 4 mo 11 d
Bug Report
40 months member
234K
Also, strangely, I noticed that when I click "Cancel" to clear out what I typed for the comment that errors on me, I immediately get "You can't post an empty comment." That seems like an odd response for when I hit Cancel as well. Not sure if that helps figure out the issue in any way or not but it was another thing I noticed.
Ezio
Ezio 5 mo 24 d
Bug Report
66 months member
3M
SentryvsSentry
It's back.
show 1 reply
Galactus
Galactus 5 mo 24 d
Bug Report
8+ year member
1.2M
I saw it. Not really harming the website, so very low priority.
JLA1847
JLA1847 10 mo 4 d
Bug Report
21 months member
5.7K
The preview doesnt actually give an accurate preview of how the image will look in 2/3 cases, rather the profile image ends up being zoomed in (or preview is zoomed out but same thing really...)

Example of what i mean:
Last edited: 10 mo 4 d ago.
show 5 replies
Galactus
Galactus 9 mo 9 d
Bug Report
8+ year member
1.2M
Just so you know, it's on my to-do list.
CaptainCool
CaptainCool 9 mo 9 d
Bug Report
10 months member
1.4K
Not a big deal tbh
JLA1847
JLA1847 8 mo 23 d
Bug Report
21 months member
5.7K
@Galactus

Ah okay, thanks a lot really happy to hear that!
RajinKabir
RajinKabir 8 mo 12 d
Bug Report
26 months member
573K
@JLA1847 if you crop the image in 3:4 ratio and then select it to add then this problem doesn't happen. The current profile shows same as the preview.
JLA1847
JLA1847 8 mo 12 d
Bug Report
21 months member
5.7K
@RajinKabir Yea that does seem to work after testing it out, hmm, well thanks a whole lot for the heads up!
Savage
Savage 1 y 3 mo 29 d
Bug Report
19 months member
30.4K
When I like or dislike a battle that already has votes, all the votes change. If I click of the battle, and then back on it, it's back to normal.
So, when I disliked a battle that already had 3 dislikes, it changed to 1 dislike. And when I liked a battle that already had 8 likes, it changed to 6
show 1 reply
Galactus
Galactus 1 y 3 mo 29 d
Bug Report
8+ year member
1.2M
Thanks for reporting.
It looks like that the moment you rate the battle, it's doesn't (visually) update the numbers correctly. It does register the right ratings, though. If you refresh the page after you rated, everything look the way t should.

I'll look into it.
Last edited: 1 y 3 mo 29 d ago.
TH0R
TH0R 1 y 4 mo 14 d
Bug Report
32 months member
45.1K
If some one privately comment me then I'm not seeing the message written ,there is written [Private Comment.]
Ezio
Ezio 1 y 10 mo 3 d
Bug Report
66 months member
3M

Sometimes the names of the characters are not displayed on the battle page.
show 5 replies
Galactus
Galactus 1 y 10 mo 3 d
Bug Report
8+ year member
1.2M
Never seen that before. What OS and browser do you use?
And what did you do to get this? Did you just add the two characters and it happened? Or was it an edit of an existing battle and you removed some characters?
Last edited: 1 y 10 mo 3 d ago.
Ezio
Ezio 1 y 10 mo 3 d
Bug Report
66 months member
3M
Win 10, Firefox, New Battle
Galactus
Galactus 1 y 10 mo 1 d
Bug Report
8+ year member
1.2M
When you encounter it again, please let me know what battle it was.
Ezio
Ezio 1 y 10 mo 1 d
Bug Report
66 months member
3M

Right now
Galactus
Galactus 1 y 3 mo 19 d
Bug Report
8+ year member
1.2M
I've kept this report to fix it some day. I have had this happen now a couple of times, which makes it easier to look into. Haven't had the time yet, though.